import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-zA-Z0-9._%-]+@[a-zA-Z0-9.-]+\\.[a-zA-Z]{2,6})*$";
final String string = "email@example.com\n"
+ "firstname.lastname@example.com\n"
+ "email@subdomain.example.com\n"
+ "1234567890@example.com\n"
+ "email@example-one.com\n"
+ "firstname-lastname@example.com\n"
+ "jpemail@example.co.jp\n"
+ "\"email\"@example.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}