package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-zA-Z0-9._%-]+@[a-zA-Z0-9.-]+\.[a-zA-Z]{2,6})*$`)
var str = `email@example.com
firstname.lastname@example.com
email@subdomain.example.com
1234567890@example.com
email@example-one.com
firstname-lastname@example.com
jpemail@example.co.jp
"email"@example.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}