#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z]{3}\s+[A-Za-z]{3}\s+\d{2}\s+(2017|(?:19\d{2}|20\d{2}))\s+.*"
Local $sString = "Fri Dec 01 2017 00:00:00 GMT-0800 (Pacific Standard Time)" & @CRLF & _
"Fri Dec 01 2016 00:00:00 GMT-0800 (Pacific Standard Time)" & @CRLF & _
"Fri Dec 01 1916 00:00:00 GMT-0800 (Pacific Standard Time)" & @CRLF & _
"Fri Dec 01 1916 00:00:00 GMT-0800 (Pacific Standard Time)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")