use strict;
my $str = 'Fri Dec 01 2017 00:00:00 GMT-0800 (Pacific Standard Time)
Fri Dec 01 2016 00:00:00 GMT-0800 (Pacific Standard Time)
Fri Dec 01 1916 00:00:00 GMT-0800 (Pacific Standard Time)
Fri Dec 01 1916 00:00:00 GMT-0800 (Pacific Standard Time)
';
my $regex = qr/^[a-zA-Z]{3}\s+[A-Za-z]{3}\s+\d{2}\s+(2017|(?:19\d{2}|20\d{2}))\s+.*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}