using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z]{3}\s+[A-Za-z]{3}\s+\d{2}\s+(2017|(?:19\d{2}|20\d{2}))\s+.*";
string input = @"Fri Dec 01 2017 00:00:00 GMT-0800 (Pacific Standard Time)
Fri Dec 01 2016 00:00:00 GMT-0800 (Pacific Standard Time)
Fri Dec 01 1916 00:00:00 GMT-0800 (Pacific Standard Time)
Fri Dec 01 1916 00:00:00 GMT-0800 (Pacific Standard Time)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}