// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-zA-Z]{3}\s+[A-Za-z]{3}\s+\d{2}\s+(2017|(?:19\d{2}|20\d{2}))\s+.*").unwrap();
let string = "Fri Dec 01 2017 00:00:00 GMT-0800 (Pacific Standard Time)
Fri Dec 01 2016 00:00:00 GMT-0800 (Pacific Standard Time)
Fri Dec 01 1916 00:00:00 GMT-0800 (Pacific Standard Time)
Fri Dec 01 1916 00:00:00 GMT-0800 (Pacific Standard Time)
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}