$re = '/^[a-zA-Z]{3}\s+[A-Za-z]{3}\s+\d{2}\s+(2017|(?:19\d{2}|20\d{2}))\s+.*/m';
$str = 'Fri Dec 01 2017 00:00:00 GMT-0800 (Pacific Standard Time)
Fri Dec 01 2016 00:00:00 GMT-0800 (Pacific Standard Time)
Fri Dec 01 1916 00:00:00 GMT-0800 (Pacific Standard Time)
Fri Dec 01 1916 00:00:00 GMT-0800 (Pacific Standard Time)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);