const regex = /^[a-zA-Z]{3}\s+[A-Za-z]{3}\s+\d{2}\s+(2017|(?:19\d{2}|20\d{2}))\s+.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z]{3}\\s+[A-Za-z]{3}\\s+\\d{2}\\s+(2017|(?:19\\d{2}|20\\d{2}))\\s+.*', 'gm')
const str = `Fri Dec 01 2017 00:00:00 GMT-0800 (Pacific Standard Time)
Fri Dec 01 2016 00:00:00 GMT-0800 (Pacific Standard Time)
Fri Dec 01 1916 00:00:00 GMT-0800 (Pacific Standard Time)
Fri Dec 01 1916 00:00:00 GMT-0800 (Pacific Standard Time)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}