using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<%([-=]):\s*([^|]*?)\s*\|\s*(\w+)\s*%>";
string substitution = @"<%\1 filters.\3(\2) %>";
string input = @"<%=: price | moneyFormat %>
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}