import re
regex = re.compile(r"<%([-=]):\s*([^|]*?)\s*\|\s*(\w+)\s*%>", flags=re.MULTILINE)
test_str = ("<%=: price | moneyFormat %>\n")
subst = "<%\\1 filters.\\3(\\2) %>"
result = regex.sub(subst, test_str)
if result:
print(result)