use strict;
my $str = '<%=: price | moneyFormat %>
';
my $regex = qr/<%([-=]):\s*([^|]*?)\s*\|\s*(\w+)\s*%>/mp;
my $subst = '<%\\1 filters.\\3(\\2) %>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";