import Foundation
let pattern = #"<%([-=]):\s*([^|]*?)\s*\|\s*(\w+)\s*%>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<%=: price | moneyFormat %>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<%\1 filters.\3(\2) %>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)