$re = '/<%([-=]):\s*([^|]*?)\s*\|\s*(\w+)\s*%>/m';
$str = '<%=: price | moneyFormat %>
';
$subst = "<%\1 filters.\3(\2) %>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;