package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<%([-=]):\s*([^|]*?)\s*\|\s*(\w+)\s*%>`)
var str = `<%=: price | moneyFormat %>
`
var substitution = "<%\1 filters.\3(\2) %>"
fmt.Println(re.ReplaceAllString(str, substitution))
}