#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\bm(?:iss|r?s?)\b (?:de |di |du |de la |van )?[a-z]+[-']?[a-z]*"
Local $sString = "i have fixed mr jones fridge. mrs jones was happy with the service. miss johnson-taylor told ms o'neil that everything was fabulous. mr van larsen was less than impressed but that was a missunderstanding."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")