$re = '/\bm(?:iss|r?s?)\b (?:de |di |du |de la |van )?[a-z]+[-\']?[a-z]*/';
$str = 'i have fixed mr jones fridge. mrs jones was happy with the service. miss johnson-taylor told ms o\'neil that everything was fabulous. mr van larsen was less than impressed but that was a missunderstanding.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);