use strict;
my $str = 'i have fixed mr jones fridge. mrs jones was happy with the service. miss johnson-taylor told ms o\'neil that everything was fabulous. mr van larsen was less than impressed but that was a missunderstanding.';
my $regex = qr/\bm(?:iss|r?s?)\b (?:de |di |du |de la |van )?[a-z]+[-']?[a-z]*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}