import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bm(?:iss|r?s?)\\b (?:de |di |du |de la |van )?[a-z]+[-']?[a-z]*";
final String string = "i have fixed mr jones fridge. mrs jones was happy with the service. miss johnson-taylor told ms o'neil that everything was fabulous. mr van larsen was less than impressed but that was a missunderstanding.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}