import Foundation
let pattern = #"\bm(?:iss|r?s?)\b (?:de |di |du |de la |van )?[a-z]+[-']?[a-z]*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"i have fixed mr jones fridge. mrs jones was happy with the service. miss johnson-taylor told ms o'neil that everything was fabulous. mr van larsen was less than impressed but that was a missunderstanding."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)