// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\bm(?:iss|r?s?)\b (?:de |di |du |de la |van )?[a-z]+[-']?[a-z]*").unwrap();
let string = "i have fixed mr jones fridge. mrs jones was happy with the service. miss johnson-taylor told ms o'neil that everything was fabulous. mr van larsen was less than impressed but that was a missunderstanding.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}