# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(#\S+)|\d+/$1/gm;t' <<< "table9 dolv5e #10n #dec10 #nov8e 23 hello"