$re = '/(#\S+)|\d+/m';
$str = 'table9 dolv5e #10n #dec10 #nov8e 23 hello';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;