using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(#\S+)|\d+";
string substitution = @"$1";
string input = @"table9 dolv5e #10n #dec10 #nov8e 23 hello";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}