re = /(#\S+)|\d+/m
str = 'table9 dolv5e #10n #dec10 #nov8e 23 hello'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result