const regex = /(#\S+)|\d+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(#\\S+)|\\d+', 'gm')
const str = `table9 dolv5e #10n #dec10 #nov8e 23 hello`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);