# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:[^aA\n]*[aA]){3}.*$/§/gm;t' <<< "Anagram
Assassination
Abaca
abba
abbb
aa bb aaa"