re = /^(?:[^aA\n]*[aA]){3}.*$/m
str = 'Anagram
Assassination
Abaca
abba
abbb
aa bb aaa'
subst = '§'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result