$re = '/^(?:[^aA\n]*[aA]){3}.*$/m';
$str = 'Anagram
Assassination
Abaca
abba
abbb
aa bb aaa';
$subst = "§";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;