const regex = /^(?:[^aA\n]*[aA]){3}.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[^aA\\n]*[aA]){3}.*$', 'gm')
const str = `Anagram
Assassination
Abaca
abba
abbb
aa bb aaa`;
const subst = `§`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);