import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[^aA\\n]*[aA]){3}.*$";
final String string = "Anagram\n"
+ "Assassination\n"
+ "Abaca\n\n"
+ "abba\n"
+ "abbb\n"
+ "aa bb aaa";
final String subst = "§";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}