package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[^aA\n]*[aA]){3}.*$`)
var str = `Anagram
Assassination
Abaca
abba
abbb
aa bb aaa`
var substitution = "§"
fmt.Println(re.ReplaceAllString(str, substitution))
}