#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^HN\d{8}[A-Z0-9]$"
Local $sString = "HN240012345" & @CRLF & _
"HN24001234Y" & @CRLF & _
"HN240012345Y" & @CRLF & _
"AN24001234Y" & @CRLF & _
"HN240X1234Y"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")