using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^HN\d{8}[A-Z0-9]$";
string input = @"HN240012345
HN24001234Y
HN240012345Y
AN24001234Y
HN240X1234Y";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}