import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^HN\\d{8}[A-Z0-9]$";
final String string = "HN240012345\n"
+ "HN24001234Y\n"
+ "HN240012345Y\n"
+ "AN24001234Y\n"
+ "HN240X1234Y";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}