// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^HN\d{8}[A-Z0-9]$").unwrap();
let string = "HN240012345
HN24001234Y
HN240012345Y
AN24001234Y
HN240X1234Y";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}