$re = '/^HN\d{8}[A-Z0-9]$/m';
$str = 'HN240012345
HN24001234Y
HN240012345Y
AN24001234Y
HN240X1234Y';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);