re = /^HN\d{8}[A-Z0-9]$/m
str = 'HN240012345
HN24001234Y
HN240012345Y
AN24001234Y
HN240X1234Y'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end