#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\[.*?support.*?\]"
Local $sString = "XT1941-4 [Type: M3B8A] (Marketing Name: Motorola One)[Support: 802.11 a/b/g/n, Bluetooth & NFC]" & @CRLF & _
"" & @CRLF & _
"XT1941-4 [Type: M3B8A] (Marketing Name: Motorola One)[asd Support: 802.11 a/b/g/n, Bluetooth & NFC]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")