$re = '/\[.*?support.*?\]/mi';
$str = 'XT1941-4 [Type: M3B8A] (Marketing Name: Motorola One)[Support: 802.11 a/b/g/n, Bluetooth & NFC]
XT1941-4 [Type: M3B8A] (Marketing Name: Motorola One)[asd Support: 802.11 a/b/g/n, Bluetooth & NFC]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);