import re
regex = re.compile(r"\[.*?support.*?\]", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("XT1941-4 [Type: M3B8A] (Marketing Name: Motorola One)[Support: 802.11 a/b/g/n, Bluetooth & NFC]\n\n"
"XT1941-4 [Type: M3B8A] (Marketing Name: Motorola One)[asd Support: 802.11 a/b/g/n, Bluetooth & NFC]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")