// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\[.*?support.*?\]").unwrap();
let string = "XT1941-4 [Type: M3B8A] (Marketing Name: Motorola One)[Support: 802.11 a/b/g/n, Bluetooth & NFC]
XT1941-4 [Type: M3B8A] (Marketing Name: Motorola One)[asd Support: 802.11 a/b/g/n, Bluetooth & NFC]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}