import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[.*?support.*?\\]";
final String string = "XT1941-4 [Type: M3B8A] (Marketing Name: Motorola One)[Support: 802.11 a/b/g/n, Bluetooth & NFC]\n\n"
+ "XT1941-4 [Type: M3B8A] (Marketing Name: Motorola One)[asd Support: 802.11 a/b/g/n, Bluetooth & NFC]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}