re = /\[.*?support.*?\]/mi
str = 'XT1941-4 [Type: M3B8A] (Marketing Name: Motorola One)[Support: 802.11 a/b/g/n, Bluetooth & NFC]
XT1941-4 [Type: M3B8A] (Marketing Name: Motorola One)[asd Support: 802.11 a/b/g/n, Bluetooth & NFC]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end