#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^6.102$"
Local $sString = "Match ENTIRE LINE of these lines:" & @CRLF & _
"" & @CRLF & _
"6.102" & @CRLF & _
"6.00" & @CRLF & _
"6.341" & @CRLF & _
"17.006" & @CRLF & _
"15.0341" & @CRLF & _
"" & @CRLF & _
"and NONE of these:" & @CRLF & _
"" & @CRLF & _
"6005" & @CRLF & _
"128.2.34.101" & @CRLF & _
"NO.DONT" & @CRLF & _
"6.5X0" & @CRLF & _
"OU.812"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")