import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^6.102$";
final String string = "Match ENTIRE LINE of these lines:\n\n"
+ "6.102\n"
+ "6.00\n"
+ "6.341\n"
+ "17.006\n"
+ "15.0341\n\n"
+ "and NONE of these:\n\n"
+ "6005\n"
+ "128.2.34.101\n"
+ "NO.DONT\n"
+ "6.5X0\n"
+ "OU.812";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}