// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^6.102$").unwrap();
let string = "Match ENTIRE LINE of these lines:
6.102
6.00
6.341
17.006
15.0341
and NONE of these:
6005
128.2.34.101
NO.DONT
6.5X0
OU.812";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}