package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^6.102$`)
var str = `Match ENTIRE LINE of these lines:
6.102
6.00
6.341
17.006
15.0341
and NONE of these:
6005
128.2.34.101
NO.DONT
6.5X0
OU.812`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}