re = /^6.102$/m
str = 'Match ENTIRE LINE of these lines:
6.102
6.00
6.341
17.006
15.0341
and NONE of these:
6005
128.2.34.101
NO.DONT
6.5X0
OU.812'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end