#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\s?\n+\s+|\n)"
Local $sString = "<all-tags " & @CRLF & _
" with-their="attribute"" & @CRLF & _
"" & @CRLF & _
" even-if-there="are-more"" & @CRLF & _
"aa="1">and all the content between" & @CRLF & _
" the start and end tag</all-tags><meta-tag />"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)