using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\s?\n+\s+|\n)";
string substitution = @" ";
string input = @"<all-tags
with-their=""attribute""
even-if-there=""are-more""
aa=""1"">and all the content between
the start and end tag</all-tags><meta-tag />";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}